policycoreutils: Privilege escalation — GLSA 201412-44

A vulnerability in policycoreutils could lead to local privilege escalation.

Affected Packages

sys-apps/policycoreutils on all architectures
Affected versions < 2.2.5-r4
Unaffected versions >= 2.2.5-r4

Background

policycoreutils is a collection of SELinux policy utilities.

Description

The seunshare utility is owned by root with 4755 permissions which can be exploited by a setuid system call.

Impact

A local attacker may be able to gain escalated privileges.

Workaround

There is no known workaround at this time.

Resolution

All policycoreutils users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=sys-apps/policycoreutils-2.2.5-r4"
 

References

Release Date
December 26, 2014

Latest Revision
December 26, 2014: 1

Severity
high

Exploitable
local

Bugzilla entries