Facter: Privilege escalation — GLSA 201412-45

An untrusted search path vulnerability in Facter could lead to local privilege escalation.

Affected Packages

dev-ruby/facter on all architectures
Affected versions < 1.7.6
Unaffected versions >= 1.7.6

Background

Facter is a cross-platform Ruby library for retrieving facts from operating systems.

Description

Facter includes the current working directory in the search path.

Impact

A local attacker may be able to gain escalated privileges.

Workaround

There is no known workaround at this time.

Resolution

All Facter users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-ruby/facter-1.7.6"
 

References

Release Date
December 26, 2014

Latest Revision
December 26, 2014: 1

Severity
high

Exploitable
local

Bugzilla entries