TORQUE Resource Manager: Multiple vulnerabilities — GLSA 201412-47

Multiple vulnerabilities have been found in TORQUE Resource Manager, possibly resulting in escalation of privileges or remote code execution.

Affected Packages

sys-cluster/torque on all architectures
Affected versions < 4.1.7
Unaffected versions >= 4.1.7
revision >= 2.5.13

Background

TORQUE is a resource manager and queuing system based on OpenPBS.

Description

Multiple vulnerabilities have been discovered in TORQUE Resource Manager. Please review the CVE identifiers referenced below for details.

Impact

A context-dependent attacker may be able to gain escalated privileges, execute arbitrary code, or bypass security restrictions.

Workaround

There is no known workaround at this time.

Resolution

All TORQUE Resource Manager 4.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=sys-cluster/torque-4.1.7"
 

All TORQUE Resource Manager 2.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=sys-cluster/torque-2.5.13"
 

NOTE: One or more of the issues described in this advisory have been fixed in previous updates. They are included in this advisory for the sake of completeness. It is likely that your system is already no longer affected by them.

References

Release Date
December 26, 2014

Latest Revision
December 26, 2014: 1

Severity
high

Exploitable
local, remote

Bugzilla entries