Wireshark: Multiple vulnerabilities — GLSA 201412-52

Multiple vulnerabilities have been found in Wireshark which could allow remote attackers to cause Denial of Service.

Affected Packages

net-analyzer/wireshark on all architectures
Affected versions < 1.12.2
Unaffected versions >= 1.12.2

Background

Wireshark is a network protocol analyzer formerly known as ethereal.

Description

Multiple vulnerabilities have been discovered in Wireshark. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker can cause a Denial of Service condition via specially crafted packets.

Workaround

There is no known workaround at this time.

Resolution

All Wireshark users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.12.2"
 

References

Release Date
December 28, 2014

Latest Revision
December 28, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries