MediaWiki: Multiple vulnerabilities — GLSA 201502-04

Multiple vulnerabilities have been found in MediaWiki, the worst of which may allow remote attackers to execute arbitrary code.

Affected Packages

www-apps/mediawiki on all architectures
Affected versions < 1.23.8
Unaffected versions >= 1.23.8
revision >= 1.22.15
revision >= 1.19.23

Background

MediaWiki is a collaborative editing software used by large projects such as Wikipedia.

Description

Multiple vulnerabilities have been discovered in MediaWiki. Please review the CVE identifiers and MediaWiki announcement referenced below for details.

Impact

A remote attacker may be able to execute arbitrary code with the privileges of the process, create a Denial of Service condition, obtain sensitive information, bypass security restrictions, and inject arbitrary web script or HTML.

Workaround

There is no known workaround at this time.

Resolution

All MediaWiki 1.23 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.23.8"
 

All MediaWiki 1.22 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.22.15"
 

All MediaWiki 1.19 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.19.23"
 

References

Release Date
February 07, 2015

Latest Revision
February 07, 2015: 1

Severity
high

Exploitable
remote

Bugzilla entries