ICU: Multiple Vulnerabilities — GLSA 201503-06

Multiple vulnerabilities have been found in ICU, possibly resulting in Denial of Service.

Affected Packages

dev-libs/icu on all architectures
Affected versions < 54.1-r1
Unaffected versions >= 54.1-r1

Background

ICU is a mature, widely used set of C/C++ and Java libraries providing Unicode and Globalization support for software applications.

Description

Multiple vulnerabilities have been discovered in ICU. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker can cause Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All ICU users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/icu-54.1-r1"
 

References

Release Date
March 14, 2015

Latest Revision
March 14, 2015: 1

Severity
normal

Exploitable
remote

Bugzilla entries