Python: Multiple vulnerabilities — GLSA 201503-10

Multiple vulnerabilities have been found in Python, the worst of which could lead to arbitrary code execution.

Affected Packages

dev-lang/python on all architectures
Affected versions < 3.3.5-r1
Unaffected versions >= 3.3.5-r1
revision >= 2.7.9-r1
revision >= 2.7.10
revision >= 2.7.11
revision >= 2.7.12
revision >= 2.7.13
revision >= 2.7.14
revision >= 2.7.15

Background

Python is an interpreted, interactive, object-oriented programming language.

Description

Multiple vulnerabilities have been discovered in Python. Please review the CVE identifiers referenced below for details.

Impact

A context-dependent attacker may be able to execute arbitrary code or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Python 3.3 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/python-3.3.5-r1"
 

All Python 2.7 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/python-2.7.9-r1"
 

References

Release Date
March 18, 2015

Latest Revision
June 17, 2015: 2

Severity
normal

Exploitable
local, remote

Bugzilla entries