Multiple vulnerabilities have been found in Python, the worst of which could lead to arbitrary code execution.
|Package||dev-lang/python on all architectures|
|Affected versions||< 3.3.5-r1|
|Unaffected versions||>= 3.3.5-r1
Python is an interpreted, interactive, object-oriented programming language.
Multiple vulnerabilities have been discovered in Python. Please review the CVE identifiers referenced below for details.
A context-dependent attacker may be able to execute arbitrary code or cause a Denial of Service condition.
There is no known workaround at this time.
All Python 3.3 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/python-3.3.5-r1"
All Python 2.7 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/python-2.7.9-r1"