X.Org X Server: Multiple vulnerabilities — GLSA 201504-06

Multiple vulnerabilities have been found in X.Org X Server, allowing attackers to execute arbitrary code or cause a Denial of Service condition.

Affected Packages

x11-base/xorg-server on all architectures
Affected versions < 1.12.4-r4
Unaffected versions >= 1.12.4-r4

Background

The X Window System is a graphical windowing system based on a client/server model.

Description

Multiple vulnerabilities have been discovered in X.Org X Server. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All X.Org X Server users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-base/xorg-server-1.12.4-r4"
 

References

Release Date
April 17, 2015

Latest Revision
April 17, 2015: 2

Severity
high

Exploitable
remote

Bugzilla entries