Exiv2: Denial of Service — GLSA 201507-03

A vulnerability in Exiv2 could lead to Denial of Service condition.

Affected Packages

media-gfx/exiv2 on all architectures
Affected versions < 0.24-r1
Unaffected versions >= 0.24-r1

Background

Exiv2 is a C++ library and a command line utility to manage image metadata.

Description

Exiv2 has a buffer overflow in the RiffVideo::infoTagsHandler function in riffvideo.cpp.

Impact

A remote attacker could possibly cause a Denial of Service condition via a specially crafted AVI file with IKEY INFO tag.

Workaround

There is no known workaround at this time.

Resolution

All Exiv2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-gfx/exiv2-0.24-r1"
 

References

Release Date
July 07, 2015

Latest Revision
July 07, 2015: 1

Severity
normal

Exploitable
remote

Bugzilla entries