LibVNCServer: Multiple vulnerabilities — GLSA 201507-07

Multiple vulnerabilities have been found in LibVNCServer, the worst of which could result in execution of arbitrary code or Denial of Service.

Affected Packages

net-libs/libvncserver on all architectures
Affected versions < 0.9.10-r1
Unaffected versions >= 0.9.10-r1

Background

LibVNCServer is a cross-platform C library that allows you to easily implement VNC server functionality in your program.

Description

Multiple vulnerabilities have been discovered in LibVNCServer. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker may be able to execute arbitrary code with the privileges of the process or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All LibVNCServer users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/libvncserver-0.9.10-r1"
 

References

Release Date
July 07, 2015

Latest Revision
July 07, 2015: 1

Severity
normal

Exploitable
remote

Bugzilla entries