MySQL: Multiple vulnerabilities — GLSA 201507-19

Multiple vulnerabilities have been found in MySQL, allowing attackers to execute arbitrary code or cause Denial of Service.

Affected Packages

dev-db/mysql on all architectures
Affected versions < 5.6.24
Unaffected versions revision >= 5.5.43
>= 5.6.24

Background

MySQL is a fast, multi-threaded, multi-user SQL database server.

Description

Multiple vulnerabilities have been discovered in MySQL. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could send a specially crafted request, possibly resulting in execution of arbitrary code with the privileges of the application or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All MySQL 5.5.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/mysql-5.5.43"
 

All MySQL 5.6.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/mysql-5.6.24"
 

References

Release Date
July 10, 2015

Latest Revision
July 10, 2015: 1

Severity
normal

Exploitable
remote

Bugzilla entries