Multiple vulnerabilities have been found in MySQL, allowing attackers to execute arbitrary code or cause Denial of Service.
|Package||dev-db/mysql on all architectures|
|Affected versions||< 5.6.24|
|Unaffected versions||revision >= 5.5.43
MySQL is a fast, multi-threaded, multi-user SQL database server.
Multiple vulnerabilities have been discovered in MySQL. Please review the CVE identifiers referenced below for details.
A remote attacker could send a specially crafted request, possibly resulting in execution of arbitrary code with the privileges of the application or a Denial of Service condition.
There is no known workaround at this time.
All MySQL 5.5.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/mysql-5.5.43"
All MySQL 5.6.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/mysql-5.6.24"
July 10, 2015
July 10, 2015: 1