Django: Multiple vulnerabilities — GLSA 201510-06

Multiple vulnerabilities have been found in Django, the worst of which may allow a remote attacker to cause Denial of Service.

Affected Packages

dev-python/django on all architectures
Affected versions < 1.8.3
Unaffected versions >= 1.8.3
revision >= 1.7.9
revision >= 1.4.21

Background

Django is a Python-based web framework.

Description

Multiple vulnerabilities have been found in Django:

  • Session backends create a new record anytime request.session was accessed (CVE-2015-5143)
  • Built-in validators in Django do not properly sanitize input (CVE-2015-5144)
  • URL validation included a regular expression that was extremely slow (CVE-2015-5145)

Impact

A remote attacker may be able cause a Denial of Service condition, inject arbitrary headers, and conduct HTTP response splitting attacks.

Workaround

There is no known workaround at this time.

Resolution

All Django 1.8 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-python/django-1.8.3"
 

All Django 1.7 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-python/django-1.7.9"
 

All Django 1.4 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-python/django-1.4.21"
 

References

Release Date
October 31, 2015

Latest Revision
October 31, 2015: 1

Severity
normal

Exploitable
remote

Bugzilla entries