A buffer overflow in GStreamer could allow remote attackers to execute arbitrary code or cause Denial of Service.
|Package||media-libs/gstreamer on all architectures|
|Affected versions||< 1.4.5|
|Unaffected versions||>= 1.4.5
revision >= 0.10.36-r2
|Package||media-libs/gst-plugins-bad on all architectures|
|Affected versions||< 0.10.23-r3|
|Unaffected versions||revision >= 0.10.23-r3|
GStreamer is an open source multimedia framework.
A buffer overflow vulnerability has been found in the parsing of H.264 formatted video.
A remote attacker could entice a user to open a specially crafted H.264 formatted video using an application linked against GStreamer, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.
There is no known workaround at this time.
All GStreamer users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/gstreamer-1.4.5"
December 30, 2015
February 09, 2016: 3