A buffer overflow in Firebird might allow remote attackers to execute arbitrary code.
|Package||dev-db/firebird on all architectures|
|Affected versions||< 18.104.22.168780.0-r3|
|Unaffected versions||>= 22.214.171.124780.0-r3|
Firebird is a multi-platform, open source relational database.
The vulnerability is caused due to an error when processing requests from remote clients.
A remote attacker could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.
There is no known workaround at this time.
All Firebird users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/firebird-126.96.36.199780.0-r3"
NOTE: Firebird package was moved to the testing branch (unstable) of Gentoo. There is currently no stable version of Firebird, and there will be no further GLSAs for this package.
December 30, 2015
December 30, 2015: 1