WebKitGTK+: Multiple vulnerabilities — GLSA 201601-02

Multiple vulnerabilities have been found in WebKitGTK+, allowing remote attackers to execute arbitrary code or cause a Denial of Service condition.

Affected Packages

net-libs/webkit-gtk on all architectures
Affected versions < 2.4.9
Unaffected versions >= 2.4.9

Background

WebKitGTK+ is a full-featured port of the WebKit rendering engine.

Description

Multiple vulnerabilities have been discovered in WebKitGTK+. Please review the CVE identifiers referenced below for details.

Impact

A remote attack can use multiple vectors to execute arbitrary code or cause a denial of service condition.

Workaround

There is no known workaround at this time.

Resolution

All WebKitGTK+ 3 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/webkit-gtk-2.4.9:3"
 

All WebKitGTK+ 2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=net-libs/webkit-gtk-2.4.9-r200:2"
 

References

Release Date
January 26, 2016

Latest Revision
January 26, 2016: 1

Severity
normal

Exploitable
remote

Bugzilla entries