OSC: Shell command injection — GLSA 201603-02

OSC is vulnerable to the remote execution of arbitrary code.

Affected Packages

dev-util/osc on all architectures
Affected versions < 0.152.0
Unaffected versions >= 0.152.0

Background

OSC is the command line tool and API for the Open Build Service.

Description

A vulnerability has been discovered that may allow remote attackers to execute arbitrary commands via shell metacharacters in a _service file.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process.

Workaround

There is no known work around at this time.

Resolution

All OSC users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-util/osc-0.152.0"
 

References

Release Date
March 06, 2016

Latest Revision
March 06, 2016: 1

Severity
normal

Exploitable
remote

Bugzilla entries