Roundcube: Multiple Vulnerabilities — GLSA 201603-03

Multiple vulnerabilities have been found in Roundcube allowing remote authenticated users to execute arbitrary code, inject arbitrary web scripts, and perform cross-site scripting (XSS).

Affected Packages

mail-client/roundcube on all architectures
Affected versions < 1.1.4
Unaffected versions >= 1.1.4

Background

Free and open source webmail software for the masses, written in PHP.

Description

Remote authenticated users with certain permissions can read arbitrary files or possibly execute arbitrary code via .. in the _skin parameter to index.php. Additionally, a cross-site scripting (XSS) vulnerability in program/js/app.js allows remote authenticated users to inject arbitrary web script or HTML via the file name in a drag-n-drop file upload.

Impact

A remote authenticated user could possibly execute arbitrary code with the privileges of the process, inject arbitrary web scripts or HTML, read arbitrary files, or perform XSS.

Workaround

There is no known workaround at this time.

Resolution

All Roundcube users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-client/roundcube-1.1.4”
 

References

Release Date
March 09, 2016

Latest Revision
March 09, 2016: 1

Severity
high

Exploitable
remote

Bugzilla entries