Xen: Multiple vulnerabilities — GLSA 201604-03

Multiple vulnerabilities have been found in Xen, the worst of which cause a Denial of Service.

Affected Packages

app-emulation/xen on all architectures
Affected versions < 4.6.0-r9
Unaffected versions >= 4.6.0-r9
revision >= 4.5.2-r5
app-emulation/xen-pvgrub on all architectures
Affected versions < 4.6.0
Unaffected versions
app-emulation/xen-tools on all architectures
Affected versions < 4.6.0-r9
Unaffected versions >= 4.6.0-r9
revision >= 4.5.2-r5
app-emulation/pvgrub on all architectures
Affected versions
Unaffected versions >= 4.6.0
revision >= 4.5.2

Background

Xen is a bare-metal hypervisor.

Description

Multiple vulnerabilities have been discovered in Xen. Please review the CVE identifiers referenced below for details.

Impact

A local attacker could possibly cause a Denial of Service condition or obtain sensitive information.

Workaround

There is no known workaround at this time.

Resolution

All Xen 4.5 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/xen-4.5.2-r5"
 

All Xen 4.6 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/xen-4.6.0-r9"
 

All Xen tools 4.5 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/xen-tools-4.5.2-r5"
 

All Xen tools 4.6 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/xen-tools-4.6.0-r9"
 

All Xen pvgrub users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/xen-pvgrub-4.6.0"
 

References

Release Date
April 05, 2016

Latest Revision
April 05, 2016: 1

Severity
normal

Exploitable
local

Bugzilla entries