Mozilla Products: Multiple vulnerabilities — GLSA 201605-06

Multiple vulnerabilities have been found in Firefox, Thunderbird, Network Security Services (NSS), and NetScape Portable Runtime (NSPR) with the worst of which may allow remote execution of arbitrary code.

Affected Packages

dev-libs/nspr on all architectures
Affected versions < 4.12
Unaffected versions >= 4.12
dev-libs/nss on all architectures
Affected versions < 3.22.2
Unaffected versions >= 3.22.2
mail-client/thunderbird on all architectures
Affected versions < 38.7.0
Unaffected versions >= 38.7.0
mail-client/thunderbird-bin on all architectures
Affected versions < 38.7.0
Unaffected versions >= 38.7.0
www-client/firefox on all architectures
Affected versions < 38.7.0
Unaffected versions >= 38.7.0
www-client/firefox-bin on all architectures
Affected versions < 38.7.0
Unaffected versions >= 38.7.0

Background

Mozilla Firefox is an open-source web browser, Mozilla Thunderbird an open-source email client, and the Network Security Service (NSS) is a library implementing security features like SSL v.2/v.3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME and X.509 certificates. The SeaMonkey project is a community effort to deliver production-quality releases of code derived from the application formerly known as ‘Mozilla Application Suite’.

Description

Multiple vulnerabilities have been discovered in Firefox, NSS, NSPR, and Thunderbird. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to view a specially crafted web page or email, possibly resulting in execution of arbitrary code or a Denial of Service condition. Furthermore, a remote attacker may be able to perform Man-in-the-Middle attacks, obtain sensitive information, spoof the address bar, conduct clickjacking attacks, bypass security restrictions and protection mechanisms, or have other unspecified impacts.

Workaround

There is no known workaround at this time.

Resolution

All NSS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/nss-3.22.2"
 

All Thunderbird users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-client/thunderbird-38.7.0"
 

All users of the Thunderbird binary package should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=mail-client/thunderbird-bin-38.7.0"
 

All Firefox 38.7.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/firefox-38.7.0"
 

All users of the Firefox 38.7.x binary package should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/firefox-bin-38.7.0"
 

References

Release Date
May 31, 2016

Latest Revision
January 20, 2017: 4

Severity
normal

Exploitable
remote

Bugzilla entries