spice: Multiple vulnerabilities — GLSA 201606-05

Multiple vulnerabilities have been found in spice, the worst of which may result in the remote execution of arbitrary code.

Affected Packages

app-emulation/spice on all architectures
Affected versions < 0.12.7-r1
Unaffected versions >= 0.12.7-r1

Background

Provides a complete open source solution for remote access to virtual machines in a seamless way so you can play videos, record audio, share usb devices and share folders without complications.

Description

Multiple vulnerabilities have been discovered in spice, please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code. Additionally, a local attacker could cause a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All spice users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/spice-0.12.7-r1"
 

References

Release Date
June 16, 2016

Latest Revision
June 16, 2016: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries