Multiple vulnerabilities have been found in ImageMagick including overflows and possible Denials of Service.
|Package||media-gfx/imagemagick on all architectures|
|Affected versions||< 18.104.22.168|
|Unaffected versions||>= 22.214.171.124|
Imagemagick is a collection of tools and libraries for many image formats.
Multiple vulnerabilities have been discovered in ImageMagick including, but not limited to, various overflows and potential Denials of Service. Please visit the references and related bug reports for additional information.
Remote attackers could potentially perform buffer overflows or conduct Denials of Service.
There is no known workaround at this time.
All ImageMagick users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-gfx/imagemagick-126.96.36.199"