libpcre: Multiple Vulnerabilities — GLSA 201607-02

Multiple vulnerabilities have been found in libpcre, the worst of which could lead to arbitrary code execution, or cause a Denial of Service condition.

Affected Packages

dev-libs/libpcre on all architectures
Affected versions < 8.38-r1
Unaffected versions >= 8.38-r1

Background

libpcre is a library providing functions for Perl-compatible regular expressions.

Description

Multiple vulnerabilities have been discovered in libpcre. Please review the CVE identifiers referenced below for details.

Impact

An attacker can possibly execute arbitrary code or create a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All libpcre users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/libpcre-8.38-r1"
 

References

Release Date
July 09, 2016

Latest Revision
July 09, 2016: 1

Severity
normal

Exploitable
remote

Bugzilla entries