MySQL and MariaDB: Multiple vulnerabilities — GLSA 201610-06

Multiple vulnerabilities have been found in MySQL and MariaDB, the worst of which could allow remote attackers to cause a Denial of Service condition or obtain sensitive information.

Affected Packages

dev-db/mysql on all architectures
Affected versions < 5.6.31
Unaffected versions >= 5.6.31
dev-db/mariadb on all architectures
Affected versions < 10.0.27
Unaffected versions revision > 5.5.51
dev-db/mariab on all architectures
Affected versions
Unaffected versions >= 10.0.27

Background

MySQL is a popular multi-threaded, multi-user SQL server. MariaDB is an enhanced, drop-in replacement for MySQL.

Description

Multiple vulnerabilities have been discovered in MySQL and MariaDB. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could exploit vulnerabilities, through multiple vectors, that affect the confidentiality, integrity, and availability of MySQL and MariaDB.

Workaround

There is no known workaround at this time.

Resolution

All MySQL users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/mysql-5.6.31"
 

All MariaDB users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/mariadb-10.0.27"
 

References

Release Date
October 11, 2016

Latest Revision
October 11, 2016: 1

Severity
normal

Exploitable
remote

Bugzilla entries