LibreOffice, OpenOffice: Multiple vulnerabilities — GLSA 201611-03

Multiple vulnerabilities have been found in both LibreOffice and OpenOffice, the worst of which allows for the remote execution of arbitrary code.

Affected Packages

app-office/libreoffice on all architectures
Affected versions < 5.1.4.2
Unaffected versions >= 5.1.4.2
app-office/libreoffice-bin on all architectures
Affected versions < 5.1.4.2
Unaffected versions >= 5.1.4.2
app-office/openoffice-bin on all architectures
Affected versions < 4.1.2
Unaffected versions >= 4.1.2

Background

LibreOffice is a powerful office suite; its clean interface and powerful tools let you unleash your creativity and grow your productivity.

Apache OpenOffice is the leading open-source office software suite for word processing, spreadsheets, presentations, graphics, databases and more.

Description

Multiple vulnerabilities have been found in both LibreOffice and OpenOffice. Please review the referenced CVE’s for specific information regarding each.

Impact

Remote attackers could obtain sensitive information, cause a Denial of Service condition, or execute arbitrary code.

Workaround

There is no known work around at this time.

Resolution

All LibreOffice users should upgrade their respective packages to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-office/libreoffice-5.1.4.2"
 # emerge --ask --oneshot --verbose
 ">=app-office/libreoffice-bin-debug-5.1.4.2"
 

All OpenOffice users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-office/openoffice-bin-4.1.2"
 

References

Release Date
November 04, 2016

Latest Revision
April 17, 2017: 2

Severity
normal

Exploitable
remote

Bugzilla entries