ARJ: Multiple vulnerabilities — GLSA 201612-15

Multiple vulnerabilities have been found in ARJ, the worst of which may allow attackers to execute arbitrary code.

Affected Packages

app-arch/arj on all architectures
Affected versions < 3.10.22-r5
Unaffected versions >= 3.10.22-r5

Background

Open-source implementation of the ARJ archiver.

Description

Multiple vulnerabilities have been discovered in ARJ. Please review the CVE identifiers referenced below for details.

Impact

An attacker, using a specially crafted ARJ archive, could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All ARJ users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-arch/arj-3.10.22-r5"
 

References

Release Date
December 06, 2016

Latest Revision
December 06, 2016: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries