Mercurial: Multiple vulnerabilities — GLSA 201612-19

Multiple vulnerabilities have been found in Mercurial, the worst of which could lead to the remote execution of arbitrary code.

Affected Packages

dev-vcs/mercurial on all architectures
Affected versions < 3.8.4
Unaffected versions >= 3.8.4

Background

Mercurial is a distributed source control management system.

Description

Multiple vulnerabilities have been discovered in Mercurial. Please review the CVE identifier and bug reports referenced for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process.

Workaround

There is no known workaround at this time.

Resolution

All mercurial users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-vcs/mercurial-3.8.4"
 

References

Release Date
December 07, 2016

Latest Revision
December 07, 2016: 1

Severity
normal

Exploitable
remote

Bugzilla entries