Node.js: Multiple vulnerabilities — GLSA 201612-43

Multiple vulnerabilities have been found in Node.js, the worst of which can allow remote attackers to cause Denial of Service conditions.

Affected Packages

net-libs/nodejs on all architectures
Affected versions < 4.6.1
Unaffected versions revision >= 0.12.17
>= 4.6.1

Background

Node.js is a JavaScript runtime built on Chrome’s V8 JavaScript engine.

Description

Multiple vulnerabilities have been discovered in Node.js. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly cause a Denial of Service condition, or conduct man-in-the-middle attacks.

Workaround

There is no known workaround at this time.

Resolution

All Node.js 0.12.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/nodejs-0.12.17"
 

All Node.js 4.6.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/nodejs-4.6.1"
 

References

Release Date
December 13, 2016

Latest Revision
December 13, 2016: 1

Severity
normal

Exploitable
remote

Bugzilla entries