Multiple vulnerabilities have been found in Node.js, the worst of which can allow remote attackers to cause Denial of Service conditions.
|Package||net-libs/nodejs on all architectures|
|Affected versions||< 4.6.1|
|Unaffected versions||revision >= 0.12.17
Multiple vulnerabilities have been discovered in Node.js. Please review the CVE identifiers referenced below for details.
A remote attacker could possibly cause a Denial of Service condition, or conduct man-in-the-middle attacks.
There is no known workaround at this time.
All Node.js 0.12.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-libs/nodejs-0.12.17"
All Node.js 4.6.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-libs/nodejs-4.6.1"