Samba: Multiple vulnerabilities — GLSA 201612-47

Multiple vulnerabilities have been found in Samba, the worst of which may allow execution of arbitrary code with root privileges.

Affected Packages

net-fs/samba on all architectures
Affected versions < 4.2.11
Unaffected versions >= 4.2.11

Background

Samba is a suite of SMB and CIFS client/server programs.

Description

Multiple vulnerabilities have been discovered in samba. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with root privileges, cause a Denial of Service condition, conduct a man-in-the-middle attack, obtain sensitive information, or bypass file permissions.

Workaround

There is no known workaround at this time.

Resolution

All Samba users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-fs/samba-4.2.11"
 

References

Release Date
December 24, 2016

Latest Revision
December 24, 2016: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries