Pidgin: Multiple vulnerabilities — GLSA 201701-38

Multiple vulnerabilities have been found in Pidgin, the worst of which could lead to execution of arbitrary code.

Affected Packages

net-im/pidgin on all architectures
Affected versions < 2.11.0
Unaffected versions >= 2.11.0

Background

Pidgin is a client for a variety of instant messaging protocols.

Description

Multiple vulnerabilities have been discovered in Pidgin. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker might send specially crafted data using the MXit protocol, possibly resulting in the remote execution of arbitrary code with the privileges of the process, a Denial of Service condition, or in leaking confidential information.

Workaround

There is no known workaround at this time.

Resolution

All Pidgin users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-im/pidgin-2.11.0"
 

References

Release Date
January 17, 2017

Latest Revision
January 17, 2017: 01

Severity
normal

Exploitable
remote

Bugzilla entries