libupnp: Multiple vulnerabilities — GLSA 201701-52

Multiple vulnerabilities have been found in libupnp, the worst of which could lead to the execution of arbitrary code.

Affected Packages

net-libs/libupnp on all architectures
Affected versions < 1.6.21
Unaffected versions >= 1.6.21

Background

libupnp is a portable, open source, UPnP development kit.

Description

Multiple vulnerabilities have been discovered in libupnp. Please review the CVE identifiers referenced below for details.

Impact

A remote attack could arbitrarily write files to a users file system, cause a Denial of Service condition, or execute arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All libupnp users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/libupnp-1.6.21"
 

References

Release Date
January 23, 2017

Latest Revision
January 23, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries