DirectFB: Multiple vulnerabilities — GLSA 201701-55

Multiple vulnerabilities have been found in DirectFB, all of which could allow remote attackers to execute arbitrary code.

Affected Packages

dev-libs/DirectFB on all architectures
Affected versions < 1.7.5
Unaffected versions >= 1.7.5

Background

DirectFB (Direct Frame Buffer) is a set of graphics APIs implemented on top of the Linux Frame Buffer (fbdev) abstraction layer.

Description

Multiple vulnerabilities have been discovered in DirectFB. Please review the CVE identifiers referenced below for details.

Impact

Remote attackers could cause a Denial of Service condition or execute arbitrary code via the Voodoo interface.

Workaround

There is no known workaround at this time.

Resolution

All DirectFB users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/DirectFB-1.7.5"
 

References

Release Date
January 23, 2017

Latest Revision
January 23, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries