Multiple vulnerabilities have been found in ImageMagick, the worst of which allows remote attackers to execute arbitrary code.
|Package||media-gfx/imagemagick on all architectures|
|Affected versions||< 126.96.36.199|
|Unaffected versions||>= 188.8.131.52|
ImageMagick is a collection of tools and libraries for many image formats.
Multiple vulnerabilities have been discovered in ImageMagick. Please review the CVE identifiers referenced below for details.
A remote attacker, by enticing a user to process a specially crafted image file, could execute arbitrary code with the privileges of the process or cause a Denial of Service condition.
There is no known workaround at this time.
All ImageMagick users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-gfx/imagemagick-184.108.40.206"