Redis: Multiple vulnerabilities — GLSA 201702-16

Multiple vulnerabilities have been found in Redis, the worst of which may allow execution of arbitrary code.

Affected Packages

dev-db/redis on all architectures
Affected versions < 3.2.5
Unaffected versions >= 3.2.5
>= 3.0.7

Background

Redis is an open source (BSD licensed), in-memory data structure store, used as a database, cache and message broker.

Description

Multiple vulnerabilities have been discovered in Redis. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker, able to connect to a Redis instance, could issue malicious commands possibly resulting in the execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Redis 3.0.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/redis-3.0.7"
 

All Redis 3.2.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/redis-3.2.5"
 

References

Release Date
February 20, 2017

Latest Revision
February 20, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries