libevent: Multiple vulnerabilities — GLSA 201705-01

Multiple vulnerabilities have been found in libevent, the worst of which allows remote attackers to execute arbitrary code.

Affected Packages

dev-libs/libevent on all architectures
Affected versions < 2.1.7_rc
Unaffected versions >= 2.1.7_rc

Background

libevent is a library to execute a function when a specific event occurs on a file descriptor.

Description

Multiple vulnerabilities have been discovered in libevent. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All libevent users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/libevent-2.1.7_rc"
 

References

Release Date
May 07, 2017

Latest Revision
May 07, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries