Multiple vulnerabilities have been found in Apache Tomcat, the worst of which could lead to privilege escalation.
|Package||www-servers/tomcat on all architectures|
|Affected versions||< 8.0.36|
|Unaffected versions||>= 8.0.36
Apache Tomcat is a Servlet-3.0/JSP-2.2 Container.
Multiple vulnerabilities have been discovered in Tomcat. Please review the CVE identifiers referenced below for details.
A remote attacker may be able to cause a Denial of Service condition, obtain sensitive information, bypass protection mechanisms and authentication restrictions.
A local attacker, who is a tomcat’s system user or belongs to tomcat’s group, could potentially escalate privileges.
There is no known workaround at this time.
All Apache Tomcat users have to manually check their Tomcat runscripts to make sure that they don’t use an old, vulnerable runscript. In addition:
All Apache Tomcat 7 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-servers/tomcat-7.0.70:7"
All Apache Tomcat 8 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-servers/tomcat-8.0.36:8"