Apache Tomcat: Multiple vulnerabilities — GLSA 201705-09

Multiple vulnerabilities have been found in Apache Tomcat, the worst of which could lead to privilege escalation.

Affected Packages

www-servers/tomcat on all architectures
Affected versions < 8.0.36
Unaffected versions >= 8.0.36
>= 7.0.70

Background

Apache Tomcat is a Servlet-3.0/JSP-2.2 Container.

Description

Multiple vulnerabilities have been discovered in Tomcat. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker may be able to cause a Denial of Service condition, obtain sensitive information, bypass protection mechanisms and authentication restrictions.

A local attacker, who is a tomcat’s system user or belongs to tomcat’s group, could potentially escalate privileges.

Workaround

There is no known workaround at this time.

Resolution

All Apache Tomcat users have to manually check their Tomcat runscripts to make sure that they don’t use an old, vulnerable runscript. In addition:

All Apache Tomcat 7 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-servers/tomcat-7.0.70:7"
 

All Apache Tomcat 8 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-servers/tomcat-8.0.36:8"
 

References

Release Date
May 18, 2017

Latest Revision
May 18, 2017: 1

Severity
high

Exploitable
local, remote

Bugzilla entries