Graphite: User-assisted execution of arbitrary code — GLSA 201706-25

An out-of-bounds write in Graphite might allow remote attackers to execute arbitrary code.

Affected Packages

media-gfx/graphite2 on all architectures
Affected versions < 1.3.8-r1
Unaffected versions >= 1.3.8-r1

Background

Graphite is a “smart font” system developed specifically to handle the complexities of lesser-known languages of the world.

Description

An out-of-bounds write has been found in the Graphite 2 library.

Impact

A remote attacker could entice a user to open a specially crafted document using Graphite or an application linked against Graphite library, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Graphite users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-gfx/graphite2-1.3.8-r1"
 

References

Release Date
June 22, 2017

Latest Revision
June 22, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries