LibreOffice: Multiple vulnerabilities — GLSA 201706-28

Multiple vulnerabilities have been found in LibreOffice, the worst of which allows for the remote execution of arbitrary code.

Affected Packages

app-office/libreoffice on all architectures
Affected versions < 5.2.7.2
Unaffected versions >= 5.2.7.2
app-office/libreoffice-bin on all architectures
Affected versions < 5.2.7.2
Unaffected versions >= 5.2.7.2

Background

LibreOffice is a powerful office suite; its clean interface and powerful tools let you unleash your creativity and grow your productivity.

Description

Multiple vulnerabilities have been discovered in LibreOffice. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to open a specially crafted file using LibreOffice, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All LibreOffice users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-office/libreoffice-5.2.7.2"
 

All LibreOffice binary users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=app-office/libreoffice-bin-5.2.7.2"
 

References

Release Date
June 27, 2017

Latest Revision
June 27, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries