virglrenderer: Multiple vulnerabilities — GLSA 201707-06

Multiple vulnerabilities have been found in virglrenderer, the worst of which could allow local guest OS users to cause a Denial of Service condition.

Affected Packages

media-libs/virglrenderer on all architectures
Affected versions < 0.6.0
Unaffected versions >= 0.6.0

Background

A virtual 3D GPU library, that allows the guest operating system to use the host GPU to accelerate 3D rendering.

Description

Multiple vulnerabilities have been discovered in virglrenderer. Please review the CVE identifiers referenced below for details.

Impact

A local attacker could cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All virglrenderer users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/virglrenderer-0.6.0"
 

References

Release Date
July 08, 2017

Latest Revision
August 06, 2017: 2

Severity
normal

Exploitable
local

Bugzilla entries