feh: Arbitrary remote code execution — GLSA 201707-08

A vulnerability in feh might allow remote attackers to execute arbitrary code.

Affected Packages

media-gfx/feh on all architectures
Affected versions < 2.18.3
Unaffected versions >= 2.18.3

Background

feh is an X11 image viewer aimed mostly at console users.

Description

Tobias Stoeckmann discovered it was possible to trigger an out-of-boundary heap write with the image viewer feh while receiving an IPC message.

Impact

A remote attacker, pretending to be the E17 window manager, could possibly trigger an out-of-boundary heap write in feh while receiving an IPC message. This could result in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All feh users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-gfx/feh-2.18.3"
 

References

Release Date
July 08, 2017

Latest Revision
August 06, 2017: 2

Severity
normal

Exploitable
remote

Bugzilla entries