bzip2: Denial of Service — GLSA 201708-08

An use-after-free vulnerability has been found in bzip2 that could allow remote attackers to cause a Denial of Service condition.

Affected Packages

app-arch/bzip2 on all architectures
Affected versions < 1.0.6-r8
Unaffected versions >= 1.0.6-r8

Background

bzip2 is a high-quality data compressor used extensively by Gentoo Linux.

Description

A use-after-free flaw was found in bzip2recover, leading to a null pointer dereference, or a write to a closed file descriptor. Please review the CVE identifier referenced below for details.

Impact

A remote attacker could entice a user to process a specially crafted bzip2 archive using bzip2recover, possibly resulting in a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All bzip2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-arch/bzip2-1.0.6-r8"
 

References

Release Date
August 21, 2017

Latest Revision
August 21, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries