MCollective: Remote Code Execution — GLSA 201709-01

A vulnerability in MCollective might allow remote attackers to execute arbitrary code.

Affected Packages

app-admin/mcollective on all architectures
Affected versions < 2.11.0
Unaffected versions >= 2.11.0

Background

MCollective is a framework to build server orchestration or parallel job execution systems.

Description

A vulnerability was discovered in MCollective which allowed for deserialized YAML from agents without calling safe_load. This allows the potential for arbitrary code execution on the server.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All MCollective users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-admin/mcollective-2.11.0"
 

References

Release Date
September 04, 2017

Latest Revision
September 04, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries