PHP: Multiple vulnerabilities — GLSA 201709-21

Multiple vulnerabilities have been found in PHP, the worst of which could result in the execution of arbitrary code.

Affected Packages

dev-lang/php on all architectures
Affected versions < 5.6.31
< 7.0.23
Unaffected versions >= 5.6.31
>= 7.0.23

Background

PHP is an open source general-purpose scripting language that is especially suited for web development.

Description

Multiple vulnerabilities have been discovered in PHP. Please review the referenced CVE identifiers for details.

Impact

A remote attacker could execute arbitrary code with the privileges of the process or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All PHP 5.6.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-5.6.31"
 

All PHP 7.0.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-7.0.23"
 

References

Release Date
September 24, 2017

Latest Revision
September 25, 2017: 2

Severity
normal

Exploitable
remote

Bugzilla entries