Multiple vulnerabilities have been found in PHP, the worst of which could result in the execution of arbitrary code.
|Package||dev-lang/php on all architectures|
|Affected versions||< 5.6.31
|Unaffected versions||>= 5.6.31
PHP is an open source general-purpose scripting language that is especially suited for web development.
Multiple vulnerabilities have been discovered in PHP. Please review the referenced CVE identifiers for details.
A remote attacker could execute arbitrary code with the privileges of the process or cause a Denial of Service condition.
There is no known workaround at this time.
All PHP 5.6.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-5.6.31"
All PHP 7.0.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-7.0.23"