PCRE: Multiple vulnerabilities — GLSA 201710-25

Multiple vulnerabilities have been found in the PCRE Library, the worst of which may allow remote attackers to cause a Denial of Service condition.

Affected Packages

dev-libs/libpcre on all architectures
Affected versions < 8.41
Unaffected versions >= 8.41

Background

The PCRE Library provides functions for Perl-compatible regular expressions.

Description

Multiple vulnerabilities have been discovered in The PCRE Library. Please review the references below for details.

Impact

A remote attacker could possibly cause a Denial of Service condition or other unspecified impacts via a specially crafted file.

Workaround

There is no known workaround at this time.

Resolution

All PCRE users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/libpcre-8.41"
 

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

References

Release Date
October 23, 2017

Latest Revision
October 23, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries