Dnsmasq: Multiple vulnerabilities — GLSA 201710-27

Multiple vulnerabilities have been found in Dnsmasq, the worst of which may allow remote attackers to execute arbitrary code.

Affected Packages

net-dns/dnsmasq on all architectures
Affected versions < 2.78
Unaffected versions >= 2.78

Background

Dnsmasq is a lightweight and easily-configurable DNS forwarder and DHCP server.

Description

Multiple vulnerabilities have been discovered in Dnsmasq. Please review the references below for details.

Impact

A remote attacker could execute arbitrary code or cause a Denial of Service condition via crafted DNS, IPv6, or DHCPv6 packets.

Workaround

There is no known workaround at this time.

Resolution

All Dnsmasq users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-dns/dnsmasq-2.78"
 

References

Release Date
October 23, 2017

Latest Revision
October 23, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries