Jython: Arbitrary code execution — GLSA 201710-28

A vulnerability in Jython may lead to arbitrary code execution.

Affected Packages

dev-java/jython on all architectures
Affected versions < 2.7.0-r2
Unaffected versions >= 2.7.0-r2

Background

An implementation of Python written in Java.

Description

It was found that Jython is vulnerable to arbitrary code execution by sending a serialized function to the deserializer.

Impact

Remote execution of arbitrary code by enticing a user to execute malicious code.

Workaround

There is no known workaround at this time.

Resolution

All Jython users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-java/jython-2.7.0-r2"
 

References

Release Date
October 29, 2017

Latest Revision
October 29, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries