VDE: Privilege escalation — GLSA 201711-11

A vulnerability was discovered in VDE which may allow local users to gain root privileges.

Affected Packages

net-misc/vde on all architectures
Affected versions < 2.3.2-r4
Unaffected versions >= 2.3.2-r4

Background

VDE is an ethernet compliant virtual network that can be spawned over a set of physical computer over the Internet.

Description

It was discovered that Gentoo’s default VDE installation suffered from a privilege escalation vulnerability in the init script. This script calls an unsafe ‘chown’ command which gives members from “qemu” group root privileges.

Impact

A local attacker could escalate privileges to root.

Workaround

There is no known workaround at this time.

Resolution

All VDE users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/vde-2.3.2-r4"
 

References

Release Date
November 12, 2017

Latest Revision
November 12, 2017: 1

Severity
normal

Exploitable
local

Bugzilla entries