collectd: Multiple vulnerabilities — GLSA 201803-10

Gentoo's collectd package contains multiple vulnerabilities, the worst of which may allow local attackers to escalate privileges.

Affected Packages

app-admin/collectd on all architectures
Affected versions < 5.7.2-r1
Unaffected versions >= 5.7.2-r1

Background

collectd is a daemon which collects system and application performance metrics periodically and provides mechanisms to store the values in a variety of ways, for example in RRD files.

Description

Multiple vulnerabilities have been found in Gentoo’s collectd package. Please review the referenced CVE identifiers and bug entries for details.

Impact

A local attacker, who either is already collectd’s system user or belongs to collectd’s group, could potentially gain root privileges and cause a Denial of Service condition.

Remote attackers could cause a Denial of Service condition via specially crafted SNMP responses.

Workaround

There is no known workaround at this time.

Resolution

All collectd users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-admin/collectd-5.7.2-r1"
 

References

Release Date
March 22, 2018

Latest Revision
March 22, 2018: 1

Severity
high

Exploitable
local, remote

Bugzilla entries