libxslt: Multiple vulnerabilities — GLSA 201804-01

Multiple vulnerabilities were discovered in libxslt, the worst of which may allow a remote attacker to execute arbitrary code.

Affected Packages

dev-libs/libxslt on all architectures
Affected versions < 1.1.30
Unaffected versions >= 1.1.30

Background

libxslt is the XSLT C library developed for the GNOME project. XSLT is an XML language to define transformations for XML.

Description

Multiple vulnerabilities have been discovered in libxslt. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker, via a crafted HTML page, could possibly execute arbitrary code, cause a Denial of Service condition or leak information.

Workaround

There is no known workaround at this time.

Resolution

All libxslt users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/libxslt-1.1.30"
 

References

Release Date
April 04, 2018

Latest Revision
April 04, 2018: 1

Severity
normal

Exploitable
remote

Bugzilla entries