SoX: Multiple vulnerabilities — GLSA 201810-02

Multiple vulnerabilities have been found in SoX, the worst of which may lead to a Denial of Service condition.

Affected Packages

media-sound/sox on all architectures
Affected versions < 14.4.2-r1
Unaffected versions >= 14.4.2-r1

Background

SoX is a command line utility that can convert various formats of computer audio files in to other formats.

Description

Multiple vulnerabilities have been discovered in SoX. Please review the referenced CVE identifiers for details.

Impact

A remote attacker, by enticing a user to process a crafted WAV, HCOM, SND, or AIFF file, could cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All SoX users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-sound/sox-14.4.2-r1"
 

References

Release Date
October 06, 2018

Latest Revision
October 06, 2018: 1

Severity
normal

Exploitable
remote

Bugzilla entries