xkbcommon: Multiple vulnerabilities — GLSA 201810-05

Multiple vulnerabilities have been found in xkbcommon, the worst of which may lead to a Denial of Service condition.

Affected Packages

x11-libs/libxkbcommon on all architectures
Affected versions < 0.8.2
Unaffected versions >= 0.8.2

Background

xkbcommon is a library to handle keyboard descriptions, including loading them from disk, parsing them and handling their state.

Description

Multiple vulnerabilities have been discovered in libxkbcommon. Please review the CVE identifiers referenced below for details.

Impact

A local attacker could supply a specially crafted keymap file possibly resulting in a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All libxkbcommon users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-libs/libxkbcommon-0.8.2"
 

References

Release Date
October 30, 2018

Latest Revision
October 30, 2018: 1

Severity
normal

Exploitable
local

Bugzilla entries